Instalacja Debiana: nie wykryto napędu CD-ROM

Od dawna instaluję Debiana z pendrive’a. Zawsze używałem programu UNetbootin do nagrywania obrazu płyty instalacyjnej na pendrive’ie. Zazwyczaj instalacja zajmuje mi jakieś 30 minut. Ale nie tym razem. Tym razem męczyłem się z instalacją jakieś trzy godziny.

Zaczęło się dobrze: laptop uruchomił się z pendrive’a, pokazał menu instalatora, wybrałem instalację graficzną. W kolejnych krokach wybrałem język polski i polski układ klawiatury, a potem… instalator oświadczył, że nie wykrył CD-ROMu i zapytał czy chcę załadować sterowniki z innego nośnika.

Pominę pełen opis prób i błędów, które popełniłem, wymienię je tylko w telegraficznym skrócie:

  • To błąd w instalatorze, należy spróbować innego obrazu płyty.
  • Ponoć pendrive sformatowany na FAT32 może sprawiać problemy. Lepiej użyć FAT16.
  • Pendrive należy włożyć w port USB 2, porty USB 3 mogą sprawiać problemy.
  • Po wyświetleniu komunikatu należy wyjąć i ponownie włożyć pendrive.
  • W menu BIOS/UEFI należy zmienić opcję obsługi dysków na AHCI.

Tymczasem rozwiązaniem okazało się nagranie obrazu płyty na pendrive’a poleceniem dd:

dd bs=4M if=/home/michal/Pobrane/debian-testing-amd64-netinst.iso of=/dev/sdb && sync

PS. Laptop to był Dell Inspiron z serii 3000, nic fikuśnego. Niestety standardowo miał zainstalowanego Windowsa.

3 myśli na temat “Instalacja Debiana: nie wykryto napędu CD-ROM”

  1. Dzisiaj kupiłem tego samego laptopa (ta same seria), z zainstalowanym Ubuntu. Od razu pobrałem najnowszego Debiana, wykorzystując Universal USB Installer przygotowałem pendrive do instalacji i również spotkałem ten samo komunikat błędu, co autor artykułu. Wpisując treść komunikatu w Google, trafiłem na tego bloga i już pomyślałem że coś jest nie tak z laptopami Della (może coś w UEFI), ale spróbowałem uruchomić instalator Debiana na 4 innych komputerach (nowe, stare, BIOS, UEFI) i natknąłem się na podobny komunikat błędu. Debian 8.2, obraz DVD (przy 8.1 nie było problemów).

    1. Ja też próbowałem kilku obrazów (najpierw testing, potem stable), ale na każdym było to samo. Wersji stable nie pamiętam, możliwe że to było 8.1.

      Teraz mam Toshibę Portege Z30 i jeśli mnie pamięć nie myli przy instalacji nie miałem żadnych problemów, choć być może od razi użyłem dd.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *